font

Google Earth for Linux - Beta

OK, so Goole has finally released a first version of Google Earth for Linux (beta, of course).

Well, maybe this time they really mean it when they say "beta"...
Google Earth Linux 1 Google Earth Linux 2 Google Earth Linux 3
Here's some quick observations:

  • Of course, it's not open source, you basically get a bunch of *.so files and an executable.
  • It uses a bunch of open source software packages, though, e.g. libcurl, OpenSSL, libjpeg, libPNG, libtiff, libmng, zlib, Expat XML Parser, FreeImage, and a bunch of other things. All the licenses of those projects are contained in a README, though.
  • The installer seems to be (based on) the Loki installer, at least a ~/.loki directory is created with some stuff in it.
  • The maps cache, and some other files are stored in ~/.googleearth.
  • The ~/.googleearth/crashlogs directory contains log files which are generated when the application crashes, and sent to Google upon the next restart of the application automatically. The README says that you should basically chmod 000 ~/.googleearth/crashlogs if you don't want that. They say these files don't contain personal information. I haven't seen one yet (didn't crash, yet), so I cannot tell if that's true.
  • The EULA says that Google Earth will phone home (they call it "check for available updates to the Software"), and that you automatically agree to that when you use it: "By installing the Software, you agree to automatically request and receive Updates".
  • When I start Google Earth, I get a popup window which tells me to install Bitstream Vera Sans fonts or things might look strange. No idea which fonts extactly they mean, I've got the Debian packages ttf-bitstream-vera, and ttf-dejavu, but the warning still appears.
  • After Google Earth connects to the server(s) I get to see something resembling a globe, but not really what I (or Google possibly) expected. There's simply no textures for anything, I just see (broken) wireframes (see screenshot), but that's about it.

I'll have to play around with it a bit more, maybe it's an issue with the NVIDIA drivers or something. But as I don't have the source I can basically just make stupid guesses...

(via Golem, and a bunch of other sites)

Syndicate content