Updated Miro (previously Democracy Player) packages in Debian unstable

Miro screenshot

FYI, my new Miro packages (formerly known as Democracy Player) have now reached unstable.

After lots of ugly, ugly trouble with even getting a successful build (boost/python/dbus related, you don't want to know) the packages are back in shape now, with tons of fixed (or no longer reproducible) bugs and lots of upstream impovements and new features.

If you reported a bug against Democracy Player, please try the latest Miro package and check if it still occurs, thanks!

The upgrade should be seamless, your existing config and videos will be migrated from ~/.democracyplayer to ~/.miro automatically upon the first start of Miro.

Some of the new/fixed things in this release include:

  • HTTP proxy support (uses the GNOME proxy settings, use gconf-editor to change them).
  • Flash videos now play fine (non-jerky) and with sound!
  • You can search various video sites (Youtube, Google video, etc.) online, and even save searches as channels.
  • You can export your channel list into an OPML file (and also import OPML files, of course). I've been waiting for this for a very long time (it's a good way to backup your channel list, or move it to another machine)...
  • Lots and lots of bugfixes and small enhancements, as usual.

Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

thanks for this good work

thanks for this good work العاب فلاش

Error when starting Miro

First off, thank for the packages! Unfortunately, I'm seeing the following error when attempting to run Miro:

Traceback (most recent call last):
File "/usr/bin/miro.real", line 106, in ?
startapp()
File "/usr/bin/miro.real", line 54, in startapp
import singleclick
File "/var/lib/python-support/python2.4/miro/singleclick.py", line 35, in ?
import app
File "/var/lib/python-support/python2.4/miro/app.py", line 611, in ?
import frontend
File "/var/lib/python-support/python2.4/miro/frontend.py", line 51, in ?
from frontend_implementation.MainFrame import MainFrame, NullDisplay
File "/var/lib/python-support/python2.4/miro/frontend_implementation/MainFrame.py", line 38, in ?
from frontend_implementation import trayicon
File "/var/lib/python-support/python2.4/miro/frontend_implementation/trayicon.py", line 31, in ?
class Trayicon(gtk.StatusIcon):
AttributeError: 'module' object has no attribute 'StatusIco

Fluxbox is my Window Manager. While most everything is Etch, Miro install from Sid w/o issue. Any ideas?

Regards,

Cecil

Same Error

I'm receiving the same error.
Any fix for this?

KP

BTS

Wrong place to report. Please file a bug report in the BTS if you see the same problem with the lastest Miro version from unstable.

Uwe.

AMD64

Only miro-data is in the amd64 repositories. Is there going to be an 64 bit package?

Any word on this because

Any word on this because only miro-data is available still.

Busy

Yeah, sorry, I was pretty busy with other stuff. I'm taking patches though, if you want to speed up things :)

64 bit Miro

Yes, of course. I'm running one instance on my amd64 box just fine, but it seems I missed a build dependency!? Will investigate, the next upload should fix this.

Uwe.

Hooray!

Excellent. *rubs hands in Mr Burns style*

Many thanks for the continued great work, it's appreciated.

Nice work man , Go on

Nice work man , Go on